
Modifying Your Drawings

INTRODUCTION
The heart of any CAD system is its ability to modify and manipulate existing geometry, and
AutoCAD is no exception. Many modify commands relieve the designer of drudgery
and mundane tasks, and this allows more productive time for conceptualizing the design.
This chapter will break all AutoCAD modify commands down into two separate groupings;
the first grouping is called Level I and will cover the MOVE, COPY, SCALE, ROTATE,
OFFSET, FILLET, CHAMFER, TRIM EXTEND, and BREAK commands.The second grouping
is called Level II and will cover the ARRAY, MIRROR, STRETCH, PEDIT, EXPLODE,
LENGTHEN, JOIN, UNDO, and REDO commands. A number of small exercises accom-
pany each command in order to reinforce the importance of its use.

METHODS OF SELECTING MODIFY COMMANDS

As with all commands, you can find the main body of modify commands on the
Modify pull-down menu, as shown on the left in the following image, or through
the Modify and Modify II toolbars, both shown in the following image. Other
ways to activate modify commands are through the Modify tool palette and the 2D
Draw dashboard, as shown in the following image.

You can also enter all modify commands directly from the keyboard either using
their entire name or through command aliasing, as in the following examples.

Enter F for the FILLET command

Enter M for the MOVE command

Figure 4.1
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LEVEL I MODIFY COMMANDS

With all the modify commands available in AutoCAD, the following represent beginning,
or Level I, commands, which you will find yourself using numerous times as you make
changes to your drawing. These commands are briefly described in the following table:

Button Tool Shortcut Function
Move M Used for moving objects from one location to another

Copy Cp or Co Used for copying objects from one location to another

Scale Sc Used for increasing or reducing the size of objects

Rotate Ro Used for rotating objects to a different angle

Fillet F Used for rounding off the corners of objects at a specified radius

Chamfer Cha Used to connect two objects with an angled line forming a bevel

Offset O Used for copying objects parallel to one another at a specified
distance

Trim Tr Used for partially deleting objects based on a cutting edge

Extend Ex Used for extending objects based on a boundary edge

Break Br Creates a gap in an object between two specified points

Break at
Point

Br Breaks an object into two objects at a specified point without a
gap present

MOVING OBJECTS

The MOVE command repositions an object or group of objects at a new location.
Choose this command from one of the following:

� The Modify toolbar or the Dashboard (2D Draw Control Panel)

� The pull-down menu (Modify > Move)

� The keyboard (M or MOVE)

� By right-clicking the mouse after selecting object

Once the objects to move are selected, AutoCAD prompts the user to select a base point
of displacement (where the object is to move from). Next, AutoCAD prompts the user to
select a second point of displacement (where the object is to move to), as shown in the
following image.

Command: M (For MOVE)
Select objects: (Select the bed, as shown in the

following image)
Select objects: (Press ENTER to continue)
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Specify base point or displacement: (Select the endpoint of the
bed at “A”)

Specify second point of displacement or <use first point as
displacement>: (Mark a point at “B”)

TryIt!: Open the drawing file 04_Move.The slot as shown on the left in the following
image is incorrectly positioned; it needs to be placed 1.00 unit away from the left edge
of the object.You can use the MOVE command in combination with a polar coordinate
or Direct Distance mode to perform this operation. Use this illustration and the
following command sequence for performing this operation.

Command: M (For MOVE)
Select objects: (Select the slot and all centerlines)
Select objects: (Press ENTER to continue)
Specify base point or displacement: (Select the edge of arc “A”)
Specify second point of displacement or <use first point as

displacement>: @.50<0 (or turn Polar on, move your cursor to
the right, and type .50 at the command prompt)

As the slot is moved to a new position with the MOVE command, a new horizontal
dimension must be placed to reflect the correct distance from the edge of the object to the
centerline of the arc, as shown in the following image. The STRETCH command affects
a group of objects along with the dimension and will be explained later in this chapter.

Figure 4.2
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PRESS AND DRAG MOVE

If accuracy is not important and you simply need to move an object or group of objects to
a new approximate location, you can use a press and drag technique. First, select the objects
at the command prompt. Then, press and hold down the left mouse button on one of the
highlighted objects (not one of the blue grips), and drag the objects to the new location.

COPYING OBJECTS

The COPY command is used to duplicate an object or group of objects. Choose this
command from one of the following:

� The Modify toolbar or the Dashboard (2D Draw Control Panel)

� The pull-down menu (Modify > Copy)

� The keyboard (CP or COPY)

� By right-clicking the mouse after selecting object

Once the COPY command is executed, the multiple copy mode is on. To duplicate
numerous objects while staying inside the COPY command, simply keep picking new
second points of displacement and the objects will copy to these new locations, as shown
in the following image. Once the copy is completed, press ENTER or ESC to exit.

Command: CP (For COPY)
Select objects: (Select the chair to copy)
Select objects: (Press ENTER to continue)
Specify base point or displacement: (Pick a reference point for

the copy operation)
Specify second point of displacement or <use first point as

displacement>: (Pick a location for the first copy)
Specify second point of displacement [Exit/Undo] <Exit>: (Pick a

location for the second copy)
Specify second point of displacement [Exit/Undo] <Exit>: (Pick a

location for the third copy)
Specify second point of displacement [Exit/Undo] <Exit>: (Press

ENTER or ESC to exit this command)

Figure 4.3
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TryIt!: Open the drawing file 04_Copy Multiple. Follow the command sequence in the
previous example to copy the three holes multiple times. Use the intersection of “A”
as the base point for the copy.Then copy the three holes to the intersections located
at “B,” “C,” “D,” “E,” “F,” “G,” “H,” and “J,” as shown in the following image.

PRESS AND DRAG COPY

As with the MOVE command, you can also use the press and drag technique to copy
objects to a new approximate location. First, select the objects at the command prompt.
Then, press and hold down the right mouse button on one of the highlighted objects (not
one of the blue grips), and drag the objects to the new location. When you release the
mouse button a menu displays, as shown in the following image. Select the Copy Here
item to copy the item or group of items.

Figure 4.4

Figure 4.5
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SCALING OBJECTS

Use the SCALE command to change the overall size of an object. The size may be
larger or smaller in relation to the original object or group of objects. The SCALE
command requires a base point and scale factor to complete the command. Choose this
command from one of the following:

� The Modify toolbar or the Dashboard (2D Draw Control Panel)

� The pull-down menu (Modify > Scale)

� The keyboard (SC or SCALE)

� By right-clicking the mouse after selecting object

TryIt!: Open the drawing file 04_Scale1.With a base point at “A” and a scale factor
of 0.50, the results of using the SCALE command on a group of objects are shown in
the following image.

Command: SC (For SCALE)
Select objects: All
Select objects: (Press ENTER to continue)
Specify base point: (Select the endpoint of the line at “A”)
Specify scale factor or [Scale/Reference]: 0.50

TryIt!: Open the drawing file 04_Scale2.The example in the following image shows the
effects of identifying a new base point in the center of the object.

Command: SC (For SCALE)
Select objects: All
Select objects: (Press ENTER to continue)

Figure 4.6

Figure 4.7
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Specify base point: (Pick a point near “A”)
Specify scale factor or [Scale/Reference]: 0.40

Note: After identifying the base point for the scaling operation, you can use the Copy
option to create a scaled copy of the objects you are scaling.

SCALE—REFERENCE

Suppose you are given a drawing that has been scaled down in size. However, no one
knows what scale factor was used. You do know what one of the distances should be. In
this special case, you can use the Reference option of the SCALE command to identify
endpoints of a line segment that act as a reference length. Entering a new length value
could increase or decrease the entire object proportionally.

TryIt!: Open the drawing file 04_Scale Reference. Study the following image and the
following prompts for performing this operation.

Command: SC (For SCALE)
Select objects: (Pick a point at “A”)
Specify opposite corner: (Pick a point at “B”)
Select objects: (Press ENTER to continue)
Specify base point: (Select the edge of the circle to identify

its center)
Specify scale factor or [Scale/Reference]: R (For Reference)
Specify reference length <1>: (Select the endpoint of the line

at “C”)
Specify second point: (Select the endpoint of the line at “D”)
Specify new length: 2.00

Because the length of line “CD” was not known, the endpoints were picked after the
Reference option was entered. This provided the length of the line to AutoCAD. The final
step to perform was to make the line 2.00 units, which increased the size of the object
while also keeping its proportions.

Figure 4.8
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ROTATING OBJECTS

The ROTATE command changes the orientation of an object or group of objects by
identifying a base point and a rotation angle that completes the new orientation. Choose
this command from one of the following:

� The Modify toolbar or the Dashboard (2D Draw Control Panel)

� The pull-down menu (Modify > Rotate)

� The keyboard (RO or ROTATE)

� By right-clicking the mouse after selecting object

The following image shows an object, complete with crosshatch pattern, that needs to be
rotated to a 30° angle using point “A” as the base point.

TryIt!: Open the drawing file 04_Rotate. Use the following prompts and image to
perform the rotation.

Command: RO (For ROTATE)
Current positive angle in UCS: ANGDIR=counterclockwise ANGBASE=0
Select objects: All
Select objects: (Press ENTER to continue)
Specify base point: (Select the endpoint of the line at “A”)
Specify rotation angle or [Scale/Reference]: 30

Figure 4.9
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Note: After identifying the base point for the rotating operation, you can use the Copy
option to create a rotated copy of the objects you are rotating.

ROTATE—REFERENCE

At times it is necessary to rotate an object to a desired angular position. However, this must
be accomplished even if the current angle of the object is unknown. To maintain the
accuracy of the rotation operation, use the Reference option of the ROTATE command.
The following image shows an object that needs to be rotated to the 30°-angle position.
Unfortunately, we do not know the angle the object currently lies in. Entering the
Reference angle option and identifying two points create a known angle of reference.
Entering a new angle of 30° rotates the object to the 30° position from the reference angle.

TryIt!: Open the drawing file 04_Rotate Reference. Use the following prompts and
image to accomplish this.

Command: RO (For ROTATE)
Current positive angle in UCS: ANGDIR=counterclockwise ANGBASE=0
Select objects: (Select the object in the following image)
Select objects: (Press ENTER to continue)
Specify base point: (Pick either the edge of the circle or two

arc segments to locate the center)
Specify rotation angle or [Scale/Reference]: R (For Reference)
Specify the reference angle <0>: (Pick either the edge of the

circle or two arc segments to locate the center)
Specify second point: Mid
of (Select the line at “A” to establish the reference angle)
Specify the new angle: 30

Figure 4.10
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CREATING FILLETS AND ROUNDS

Many objects require highly finished and polished surfaces consisting of extremely
sharp corners. Fillets and rounds represent the opposite case, where corners are rounded
off, either for ornamental purposes or as required by design. Generally a fillet consists of
a rounded edge formed in the corner of an object, as illustrated in the following image. A
round is formed at an outside corner. Fillets and rounds are primarily used where objects
are cast or made from poured metal. The metal forms more easily around a shape that has
rounded corners instead of sharp corners, which usually break away. Some drawings have
so many fillets and rounds that a note is used to convey the size of them all, similar to “All
Fillets and Rounds .125 Radius.”

AutoCAD provides the FILLET command, which allows you to enter a radius followed
by the selection of two lines. The result is a fillet of the specified radius to the two lines
selected. The two lines are also automatically trimmed, leaving the radius drawn from the

Figure 4.11

Figure 4.12
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endpoint of one line to the endpoint of the other line. Choose this command from one of
the following:

� The Modify toolbar or the Dashboard (2D Draw Control Panel)

� The pull-down menu (Modify > Fillet)

� The keyboard (F or FILLET)

FILLETING BY RADIUS

Illustrated in the following image is an example of setting a radius in the FILLET
command for creating rounded-off corners.

TryIt!: Open the drawing file 04_Fillet. Follow the illustration on the left in the
following image and command sequence below to place fillets at the three corner
locations.

Command: F (For FILLET)
Current settings: Mode = TRIM, Radius = 0.0000
Select first object or [Undo/Polyline/Radius/Trim/Multiple]: R

(For Radius)
Specify fillet radius <0.0000>: 0.25
Select first object or [Undo/Polyline/Radius/Trim/Multiple]:

(Select at “A”)
Select second object or shift-select to apply corner: (Select at

“B”)
Command:
(Press ENTER to re-execute this command)

Repeat this procedure for creating additional fillets using lines “BC” and “CD.” When finished,
your display should appear similar to the illustration on the right in the following image.

FILLET AS A CORNERING TOOL

A very productive feature of the FILLET command is its use as a cornering tool. To
accomplish this, set the fillet radius to a value of 0. This produces a corner out of two
non-intersecting objects.

Figure 4.13

41131_04 6/15/2007 14:7:40 Page 11

Modifying Your Drawings 11



TryIt!: Open the drawing file 04_Fillet Corner1. Follow the illustration on the left in
the following image and the command sequence below for performing this task.

Command: F (For FILLET)
Current settings: Mode = TRIM, Radius = 0.5000
Select first object or [Undo/Polyline/Radius/Trim/Multiple]: R

(For Radius)
Enter fillet radius <0.5000>: 0
Select first object or [Undo/Polyline/Radius/Trim/Multiple]:

(Select line “A”)
Select second object or shift-select to apply corner: (Select

line “B”)

Repeat the procedure for the remaining two corners using lines “BC” and “CD.” When
finished, your display should appear similar to the illustration on the right in the following
image.

Tip: Even with a fillet radius set to a positive value, such as .50, you can easily apply a
corner to two lines by holding down the SHIFT key when picking the second object.
The use of the SHIFT key in this example temporarily sets the fillet radius to zero.
Releasing the SHIFT key sets the fillet radius back to the current value, in this case .50.

PERFORMING MULTIPLE FILLETS

Since the filleting of lines is performed numerous times, a multiple option is available that
automatically repeats the FILLET command. This option can be found by picking
Multiple from the Cursor menu or by typing M for Multiple at the command prompt.

TryIt!: Open the drawing file 04_Fillet Multiple. Activate the FILLET command and
verify that the radius is set to 0. Use the Multiple option to make the command repeat.
Then click on the corners until your object appears similar to the illustration on the
right in the following image. If you make a mistake by picking two lines incorrectly, type
U to undo this operation and still remain in the FILLET command.

Figure 4.14
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FILLETING POLYLINES

In the previous examples of using the FILLET command, you had to pick individual line
segments in order to produce one rounded corner. You also had to repeat these picks for
additional rounded corners. If the object you are filleting is a polyline, you can have the
FILLET command round off all corners of this polyline in a single pick.

TryIt!: Open the drawing file 04_Fillet Pline. Using the FILLET command on a polyline
object produces rounded edges at all corners of the polyline in a single operation.
Follow the illustration in the following image and the command sequence below for
performing this task.

Command: F (For FILLET)
Current settings: Mode = TRIM, Radius = 0.0000
Select first object or [Undo/Polyline/Radius/Trim/Multiple]: R

(For Radius)
Enter fillet radius <0.0000>: 0.25
Select first object or [Undo/Polyline/Radius/Trim/Multiple]: P

(For Polyline)
Select 2D polyline: (Select the polyline at “A”)

Figure 4.15

Figure 4.16
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NO TRIM FILLETS

The FILLET command can also be used to control whether or not to trim the excess
corners after a fillet is placed. The illustration on the left in the following image shows a
typical fillet operation where the polyline at “A” is selected. However, instead of the corners
of the polyline automatically being trimmed, a new Trim/No trim option allows the lines
to remain, as shown on the right in the following image. The following prompts illustrate
this operation.

TryIt!: Open the drawing file 04_Fillet No-Trim. Follow the command sequence and
illustration in the following image for using the No-Trim option of the FILLET
command.

Command: F (For FILLET)
Current settings: Mode = TRIM, Radius = 0.0000
Select first object or [Undo/Polyline/Radius/Trim/Multiple]: T

(For Trim)
Enter Trim mode option [Trim/No trim] <Trim>: N (For No trim)
Select first object or [Undo/Polyline/Radius/Trim/Multiple]: R

(For Radius)
Specify fillet radius <0.0000>: 0.50
Select first object or [Undo/Polyline/Radius/Trim/Multiple]: P

(For Polyline)
Select 2D polyline: (Select polyline “A”)
6 lines were filleted

Note: Reset the Trim setting in the FILLET command back to “Trim” from “No trim.”
This can be done from the keyboard by entering the commandTRIMMODE and setting
it to 1 (on).

Command: TRIMMODE
Enter new value for TRIMMODE <0>: 1

Figure 4.17
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FILLETING PARALLEL LINES

Filleting two parallel lines, as shown in the following image, automatically constructs a
semicircular arc object connecting both lines at their endpoints. When performing this
operation, it does not matter what the radius value is set to.

TryIt!: Open the drawing file 04_Fillet Parallel. Use the illustration on the left in the
following image and the command sequence below for performing this task.

Command: F (For FILLET)
Current settings: Mode = TRIM, Radius = 1.0000
Select first object or [Undo/Polyline/Radius/Trim/Multiple]:

(Select line “A”)
Select second object or shift-select to apply corner: (Select

line “B”)

Continue filleting the remaining parallel lines to complete all slots. Quicken the process by
using the Multiple option when prompted to “Select first object.”

CREATING CHAMFERS

Chamfers represent a way to finish a sharp corner of an object. The CHAMFER
command produces an inclined surface at an edge of two intersecting line segments.
Distances determine how far from the corner the chamfer is made. The following image
illustrates two examples of chamfered edges; one edge is created from unequal distances
while the other uses equal distances.

Figure 4.18
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The CHAMFER command is designed to draw an angle across a sharp corner given two
chamfer distances. Choose this command from one of the following:

� The Modify toolbar or the Dashboard (2D Draw Control Panel)

� The pull-down menu (Modify > Chamfer)

� The keyboard (CHA or CHAMFER)

CHAMFER BY EQUAL DISTANCES

The most popular chamfer involves a 45° angle, which is illustrated in the following image.
You can control this angle by entering two equal distances.

TryIt!: Open the drawing file 04_Chamfer Distances. In the example in the following
image, if you specify the same numeric value for both chamfer distances, a 45°-angled
chamfer is automatically formed.As long as both distances are the same, a 45° chamfer
will always be drawn. Study the illustration in the following image and the following
prompts:

Command: CHA (For CHAMFER)
(TRIM mode) Current chamfer Dist1 = 0.5000, Dist2 = 0.5000
Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/

Multiple]: D (For Distance)
Specify first chamfer distance <0.5000>: 0.15
Specify second chamfer distance <0.1500>: (Press ENTER to accept

the default)
Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/

Multiple]: (Select the line at “A”)
Select second line or shift-select to apply corner: (Select the

line at “B”)

Figure 4.19
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Note: When both chamfer distances are set to 0 (zero) and two edges are selected,
the effects are identical to setting the fillet radius to 0 (zero); the CHAMFER command
is used here as a cornering tool.

CHAMFER BY ANGLE

Another technique of constructing a chamfer is when one distance and the angle are given.
When the chamfer is made up of an angle other than 45°, it is commonly referred to as
a beveled edge.

TryIt!: Open the drawing file 04_Chamfer Angle. The following image illustrates the
use of the CHAMFER command by setting one distance and identifying an angle.

Command: CHA (For CHAMFER)
(TRIM mode) Current chamfer Dist1 = 0.5000, Dist2 = 0.5000
Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/

Multiple]: A (For Angle)
Specify chamfer length on the first line <0.1500>: 0.15
Specify chamfer angle from the first line <60>: 60
Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/

Multiple]: (Select the line at “A”)
Select second line or shift-select to apply corner: (Select the

line at “B”)

Figure 4.20

Figure 4.21
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CHAMFERING A POLYLINE

When working with polyline objects, you have the opportunity to select only one of the
edges of the polyline. All edges of the polyline will be chamfered to the specified distances
or angle.

TryIt!: Open the drawing file 04_Chamfer Pline. Because a polyline consists of
numerous segments representing a single object, using the CHAMFER command with
the Polyline option produces corners throughout the entire polyline, as shown in the
following image.

Command: CHA (For CHAMFER)
(TRIM mode) Current chamfer Dist1 = 0.00, Dist2 = 0.00
Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/

Multiple]: D (For Distance)
Enter first chamfer distance <0.00>: 0.50
Enter second chamfer distance <0.50>: (Press ENTER to accept the

default)
Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/

Multiple]: P (For Polyline)
Select 2D Polyline: (Select the Polyline at “A”)

Note: A Multiple option of the chamfer command allows you to chamfer edges that
share the same chamfer distances without exiting and reentering the command.

CHAMFERING WITHOUT TRIMMING

Special cases come up in the design process in which you may not wish the chamfered
edges to be automatically trimmed. Changing the Trim option to No trim in the
CHAMFER command and picking two edges creates the chamfered edge but does not
trim the lines to the chamfer.

TryIt!: Open the drawing file 04_Chamfer No-Trim. The CHAMFER command
supports a Trim/No trim option, enabling a chamfer to be placed with lines trimmed
or not trimmed, as shown in the following image. Follow the prompt sequence
carefully to set the No trim option.

Figure 4.22

41131_04 6/15/2007 16:9:0 Page 18

18



Command: CHA (For CHAMFER)
(TRIM mode) Current chamfer Dist1 = 0.2000, Dist2 = 0.2000
Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/

Multiple]: T (For Trim)
Trim/No trim <Trim>: N (For No trim)
Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple/<Select first

line>: D (For Distance)
Enter first chamfer distance <0.0000>: 1.00
Enter second chamfer distance <1.0000>: (Press ENTER to accept

the default)
Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/

Multiple]: P (For Polyline)
Select 2D Polyline: (Select the polyline at “A”)

All edges are chamfered without being trimmed.

Note: Reset the Trim setting in the CHAMFER command back to “Trim” from “No
trim.” This can be done from the keyboard by entering the command TRIMMODE and
setting it to 1 (On).

Command: TRIMMODE
Enter new value for TRIMMODE <0>: 1

CHAMFER PROJECT—BEAM

The following Try It! exercise involves the chamfering of various corners at different
distance settings.

TryIt!: Open the drawing file 04_Chamfer Beam. Using the illustration provided in the
following image, follow these directions:Apply equal chamfer distances of 0.25 units to
corners “AB,” “BC,” “DE,” and “EF.” Set new equal chamfer distances to 0.50 units and
apply these distances to corners “GH” and “JK.” Set a new first chamfer distance to
1.00; set a second chamfer distance to 0.50 units. Apply the first chamfer distance to
line “L” and the second chamfer distance to line “H.” Complete this object by applying
the first chamfer distance to line “M” and the second chamfer distance to line “K.”

Figure 4.23
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OFFSETTING OBJECTS

The OFFSET command is commonly used for creating a copy of one object that is
parallel to another. Choose this command from one of the following:

� The Modify toolbar or the Dashboard (2D Draw Control Panel)

� The pull-down menu (Modify > Offset)

� The keyboard (O or OFFSET)

OFFSETTING USING A THROUGH POINT

One method of offsetting is to identify a point to offset through, called a through point.
Once an object is selected to offset, a through point is identified. The selected object
offsets to the point shown in the following image.

TryIt!: Open the drawing file 04_Offset Through. Refer to the following image and
command sequence to use this method of the OFFSET command.

Command: O (For OFFSET)
Current settings: Erase source=No Layer=Source OFFSETGAPTYPE=0
Specify offset distance or [Through/Erase/Layer] <1.00>: T (For

Through)
Select object to offset or [Exit/Undo] <Exit>: (Select the line

at “A”)
Specify through point or [Exit/Multiple/Undo] <Exit>: Nod (For

Osnap Node)

Figure 4.24
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of (Select the point at “B”)
Select object to offset or [Exit/Undo] <Exit>: (Press ENTER to

exit this command)

OFFSETTING BY A DISTANCE

Another method of offsetting is by a specified offset distance, as shown in the
following image, where the objects need to be duplicated at a set distance from existing
geometry. The COPY command could be used for this operation; a better command would
be OFFSET. This allows you to specify a distance and a side for the offset to occur. The
result is an object parallel to the original object at a specified distance. All objects in the
following image need to be offset 0.50 toward the inside of the original object.

TryIt!: Open the drawing file 04_Offset Shape. See the command sequence and
following image to perform this operation.

Command: O (For OFFSET)
Current settings: Erase source=No Layer=Source OFFSETGAPTYPE=0
Specify offset distance or [Through/Erase/Layer] <1.00>: 0.50
Select object to offset or [Exit/Undo] <Exit>: (Select the

horizontal line at “A”)
Specify point on side to offset or [Exit/Multiple/Undo] <Exit>:

(Pick a point anywhere on the inside near “B”)

Repeat the preceding procedure for the remaining lines by offsetting them inside the
shape, as shown on the left in the following image.
Notice that when all lines were offset, the original lengths of all line segments were
maintained. Because all offsetting occurs inside, the segments overlap at their intersection
points, as shown in the middle of the following image. In one case, at “A” and “B,” the lines
did not meet at all. The FILLET command is used to edit all lines to form a sharp corner.
You can accomplish this by setting the fillet radius to 0.

Command: F (For FILLET)
Current settings: Mode = TRIM, Radius = 0.5000
Select first object or [Undo/Polyline/Radius/Trim/Multiple]: R

(For Radius)
Enter fillet radius <0.5000>: 0

Figure 4.25

41131_04 6/15/2007 16:10:17 Page 21

Modifying Your Drawings 21



Select first object or [Undo/Polyline/Radius/Trim/Multiple]:
(Select line “A”)

Select second object: (Select line “B”)

Repeat the above procedure for the remaining lines, as shown in the middle in the
following image.
Using the OFFSET command along with the FILLET command produces the result
shown on the right the following image. The fillet radius must be set to a value of 0 for
this special effect.

PERFORMING MULTIPLE OFFSETS

If you know ahead of time that you will be offsetting the same object the same preset
distance, you can use the Multiple option of the OFFSET command to work more
efficiently.

TryIt!: Open the drawing file 04_Offset Multiple. See the command sequence and
following image to perform this operation.

Command: O (For OFFSET)
Current settings: Erase source=No Layer=Source OFFSETGAPTYPE=0
Specify offset distance or [Through/Erase/Layer] <0.4000>:
Select object to offset or [Exit/Undo] <Exit>: (Pick vertical

line “A”)
Specify point on side to offset or [Exit/Multiple/Undo] <Exit>:

M (For Multiple)
Specify point on side to offset or [Exit/Undo] <next object>:

(Pick at “B”)
Specify point on side to offset or [Exit/Undo] <next object>:

(Pick at “B”)
Specify point on side to offset or [Exit/Undo] <next object>:

(Pick at “B”)
Specify point on side to offset or [Exit/Undo] <next object>:

(Press ENTER)
Select object to offset or [Exit/Undo] <Exit>: (Press ENTER

to exit)

Figure 4.26
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OTHER OFFSET OPTIONS

Other options of the OFFSET command include Erase and Layer. When the Erase
option is used, the original object you select to offset is erased after the offset copy is made.
When using the Layer option, the object being offset can take on the layer properties of
the source object or can be based on the current layer. When using the source, the offset
copy takes on the same layer as the source object you pick with offsetting. You could also
make a new layer current. Using the Current Layer mode when offsetting changes all offset
copies to the current layer. These extra offset modes allow you more flexibility with using
this command.

TRIMMING OBJECTS

Use the TRIM command to partially delete an object or a group of objects based on
a cutting edge. Choose this command from one of the following:

� The Modify toolbar or the Dashboard (2D Draw Control Panel)

� The pull-down menu (Modify > Trim)

� The keyboard (TR or TRIM)

SELECTING INDIVIDUAL CUTTING EDGES

As illustrated on the left in the following image, the four dashed lines are selected as cutting
edges. Next, segments of the circles are selected to be trimmed between the cutting edges.

TryIt!: Open the drawing file 04_Trim Basics. Use the following image and the
command sequence below to perform this task.

Command: TR (For TRIM)
Current settings: Projection=UCS Edge=None
Select cutting edges ...
Select objects or <select all>: (Select the four dashed lines on

the left in the following image)
Select objects: (Press ENTER to continue)
Select object to extend or shift-select to trim or [Fence/

Crossing/Project/Edge/eRase/Undo]: (Select the circle areas
at “A” through “D”)

Figure 4.27
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Select object to extend or shift-select to trim or [Fence/
Crossing/Project/Edge/eRase/Undo]: (Press ENTER to exit this
command)

The results of performing trim on this object are illustrated on the right in the
following image.

SELECTING ALL OBJECTS AS CUTTING EDGES

An alternate method of selecting cutting edges is to press ENTER in response to the prompt
“Select objects.” This automatically creates cutting edges out of all objects in the drawing.
When you use this method, the cutting edges do not highlight. This is a very efficient means
of trimming out unnecessary objects. You must, however, examine what you are trimming
before using this method.

TryIt!: Open the drawing file 04_Trim All. Enter the TRIM command; press ENTER at
the Select Objects prompt to select all objects as cutting edges. In the following image,
pick the lines at “A,” “B,” and “E” and the arc segments at “C” and “D” as the objects
to trim.

Command: TR (For TRIM)
Current settings: Projection=UCS Edge=None
Select cutting edges ...
Select objects: (Press ENTER to select all objects as cutting

edges)
Select object to extend or shift-select to trim or [Fence/

Crossing/Project/Edge/eRase/Undo]: (Select segments “A”
through “E”)

Select object to extend or shift-select to trim or [Fence/
Crossing/Project/Edge/eRase/Undo]: (Press ENTER to exit this
command)

Figure 4.28
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The results of performing trim on this object are illustrated on the right in the
following image.

TRIMMING BY A CROSSING BOX

When trimming objects, you do not have to pick objects individually. You can erect a
crossing box and trim objects out more efficiently.

TryIt!: Open the drawing file 04_Trim Crossing.Yet another application of the TRIM
command uses the Crossing option of “Select objects.” First, invoke the TRIM com-
mand and select the small circle as the cutting edge. Begin the response to the prompt
of “Select object to trim” with “Crossing.” See the illustration in the middle of the
following image. Turn off Running OSNAP before conducting this exercise.

Command: TR (For TRIM)
Current settings: Projection=UCS Edge=None
Select cutting edges ...
Select objects or <select all>: (Select the small circle, as

shown on the left in the following image)
Select objects: (Press ENTER to continue)
Select object to trim or shift-select to extend or [Fence/

Crossing/Project/Edge/eRase/Undo]: C (For Crossing)
Specify first corner: (Pick a corner in the middle image)
Specify opposite corner: (Pick an opposite corner in the middle

image)
Select object to trim or shift-select to extend or [Fence/

Crossing/Project/Edge/eRase/Undo]: (Press ENTER to exit this
command)

The power of the Crossing option of “Select objects” is shown on the right in the following
image. Eliminating the need to select each individual line segment inside the small circle
to trim, the Crossing mode trims all objects it touches in relation to the cutting edge.

Figure 4.29
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EXTENDING A CUTTING EDGE

The TRIM command also allows you to trim to an extended cutting edge. In Extended
Cutting Edge mode, an imaginary cutting edge is formed; all objects sliced along this
cutting edge will be trimmed if selected individually or by the Fence mode.

TryIt!: Open the drawing file 04_Trim Edge. Study the following image and prompts
on this feature of the TRIM command.

Command: TR (For TRIM)
Current settings: Projection=UCS Edge=None
Select cutting edges ...
Select objects: (Pick line “A”)
Select objects: (Press ENTER to continue)
Select object to extend or shift-select to trim or [Fence/

Crossing/Project/Edge/eRase/Undo]: E (For Edge)
Enter an implied edge extension mode [Extend/No extend] <No

extend>: E (For Extend)
Select object to extend or shift-select to trim or [Fence/

Crossing/Project/Edge/eRase/Undo]: (Pick the line at “B”
along with the other segments)

Select object to extend or shift-select to trim or [Fence/
Crossing/Project/Edge/eRase/Undo]: (Press ENTER to exit this
command)

The Fence mode can also be used to select all line segments at once to trim.

Figure 4.30
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Note: Reset the Edge setting in the TRIM command back to “No Extend” from
“Extend.” This can be done from the keyboard by entering the command EDGEMODE
and setting it to 0 (Zero).

Command: EDGEMODE
Enter new value for EDGEMODE <1>: 0

MORE ABOUT INDIVIDUAL CUTTING EDGES

Care must be taken to decide when it is appropriate to press ENTER and select all objects
in your drawing as cutting edges using the TRIM command. To see this in effect, try the
next exercise.

TryIt!: Open the drawing file 04_Trim Cut.You need to remove the six vertical lines from
the inside of the object. However, if you press ENTER to select all cutting edges, each
individual segment would need to be trimmed, which is considered unproductive. Select
lines “A” and “B” as cutting edges in the following image and select the inner vertical lines
as the objects to trim.This is considered a more efficient way of using this command.

Figure 4.31

Figure 4.32
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TRIMMING EXERCISE—FLOOR PLAN

Use any technique that you have learned to trim the walls of the floor plan in order for the
object to appear similar to the illustration in the following image.

TryIt!: Open the drawing file 04_Trim Walls. Using the following image as a guide, use
the TRIM command to trim away the extra overshoots and complete the floor plan
illustrated in the figure.

Tip: While inside the TRIM command, you can easily toggle to the EXTEND command
by holding down the SHIFT key at the following command prompt:

Select object to trim or shift-select to extend or [Fence/
Crossing/Project/Edge/eRase/Undo]:

EXTENDING OBJECTS

The EXTEND command is used to extend objects to a specified boundary edge.
Choose this command from one of the following:

� The Modify toolbar or the Dashboard (2D Draw Control Panel)

� The pull-down menu (Modify > Extend)

� The keyboard (EX or EXTEND)

Figure 4.33
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SELECTING INDIVIDUAL BOUNDARY EDGES

In the following image, select all dashed objects as the boundary edges. After pressing
ENTER to continue with the command, select the lines at “A,” “B,” “C,” and “D” to extend
these objects to the boundary edges. If you select the wrong end of an object, use the Undo
feature, which is an option of the command, to undo the change and repeat the procedure
at the correct end of the object.

TryIt!: Open the drawing file 04_Extend Basics. Use the following illustration and
command sequence for accomplishing this task.

Command: EX (For EXTEND)
Current settings: Projection=UCS Edge=None
Select boundary edges ...
Select objects: (Select the objects represented by dashes)
Select objects: (Press ENTER to continue)
Select object to extend or shift-select to trim or [Fence/

Crossing/Project/Edge/eRase/Undo]: (Select the ends of the
lines at “A” through “D”)

Select object to extend or shift-select to trim or [Fence/
Crossing/Project/Edge/eRase/Undo]: (Press ENTER to exit this
command)

Tip: An alternate method of selecting boundary edges is to press ENTER in response
to the “Select objects” prompt. This automatically creates boundary edges out of all
objects in the drawing.When you use this method, however, the boundary edges do not
highlight.

EXTENDING MULTIPLE OBJECTS

The EXTEND command can be used for extending multiple objects. After identifying the
boundary edges, you can use a number of crossing boxes to identify numerous items to
extend. This is a very productive method of using this command.

Figure 4.34
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TryIt!: Open the drawing file 04_Extend Multiple.To extend multiple objects such as
the line segments shown in the following image, select the lines at “A” and “B” as the
boundary edge and use the Crossing mode to create two crossing boxes, represented
by the dashed rectangles. This extends all line segments to intersect with the
boundaries.

Command: EX (For EXTEND)
Current settings: Projection=UCS Edge=None
Select boundary edges ...
Select objects: (Select the lines at “A” and “B”)
Select objects: (Press ENTER to continue)
Select object to extend or shift-select to trim or [Fence/

Crossing/Project/Edge/eRase/Undo]: C (For Crossing)
Specify first corner: (Pick a point to start the first

rectangle)
Specify opposite corner: (Pick a second point for the first

rectangle)
Select object to extend or shift-select to trim or [Fence/

Crossing/Project/Edge/eRase/Undo]: (Press ENTER to exit this
command)

Repeat this procedure to extend the lines on the other side of the concrete block.

EXTENDING A BOUNDARY EDGE

Certain conditions require the boundary edge to be extended where an imaginary edge is
projected, enabling objects not in direct sight of the boundary edge to still be extended.

TryIt!: Open the drawing file 04_Extend Edge. Study the following image and prompts
on this special case involving the EXTEND command.

Figure 4.35
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Command: EX (For EXTEND)
Current settings: Projection=UCS Edge=None
Select boundary edges ...
Select objects: (Pick line “A”)
Select objects: (Press ENTER to continue)
Select object to extend or shift-select to trim or [Fence/

Crossing/Project/Edge/eRase/Undo]: E (For Edge)
Enter an implied edge extension mode [Extend/No extend] <No

extend>: E (For Extend the edge)
Select object to extend or shift-select to trim or [Fence/

Crossing/Project/Edge/eRase/Undo]: (Pick line “B”)

Continue picking the remaining lines to be extended to the extended boundary edge. You
could also use the Fence or Crossing mode to select all line segments to extend. After all
lines are extended, press ENTER to exit the command.

Note: Reset the Edge setting in the EXTEND command back to “No Extend” from
“Extend.” This can be done from the keyboard by entering the command EDGEMODE
and setting it to 0 (Zero).

Command: EDGEMODE
Enter new value for EDGEMODE <1>: 0

TOGGLING FROM EXTEND TO TRIM

While inside the EXTEND command, you can easily toggle to the TRIM command by
holding down the SHIFT key at the following command prompt:

Select object to extend or shift-select to trim or [Fence/
Crossing/Project/Edge/eRase/Undo]: (Pressing SHIFT while
picking objects activates the TRIM command.)

The next Try It! exercise illustrates this technique.

Figure 4.36
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TryIt!: Open the drawing file 04_Extend and Trim. First, activate the EXTEND
command and press ENTER, which selects all edges of the object in the following
image as boundary edges.When picking the edges to extend, click on the ends of the
lines from “A” through “J,” as shown in the following image.At this point, do not exit
the command. Press and hold down the SHIFT key; this activates the TRIM command.
Now pick all of the ends of the lines until your shape appears like the illustration on
the right in the following image.The use of the SHIFT key when trimming or extending
provides a quick means of switching between commands.

EXTEND EXERCISE—PIPING DIAGRAM

TryIt!: Open the drawing file 04_Extend Pipe. Enter the EXTEND command and press
ENTER when the “Select objects:” prompt appears.This selects all objects as boundary
edges. Select the ends of all yellow lines representing pipes as the objects to extend.
They will extend to intersect with the adjacent pipe fitting. Your finished drawing
should appear similar to the following image.

Figure 4.37

Figure 4.38
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BREAKING OBJECTS

The BREAK command is used to partially delete a segment of an object. Choose this
command from one of the following:

� The Modify toolbar or the Dashboard (2D Draw Control Panel)

� The pull-down menu (Modify > Break)

� The keyboard (BR or BREAK)

BREAKING AN OBJECT

The following command sequence and image show how the BREAK command is used.

TryIt!: Open the drawing file 04_Break Gap. Turn off Running OSNAP prior to
conducting this exercise. Use the following prompts and illustrations to break the line
segment.

Command: BR (For BREAK)
Select objects: (Select the line at “A”)
Specify second break point or [First point]: (Pick the

line at “B”)

IDENTIFYING A NEW FIRST BREAK POINT

In the previous example of using the BREAK command, the location where the object was
selected became the first break point. You can select the object and then be prompted to
pick a new first point. This option resets the command and allows you to select an object
to break followed by two different points that identify the break. The following exercise
illustrates this technique.

TryIt!: Open the drawing file 04_Break First. Utilize the First option of the BREAK
command along with OSNAP options to select key objects to break. The following
command sequence and image demonstrate using the First option of the BREAK
command:

Command: BR (For BREAK)
Select object: (Select the line)
Specify second break point or [First point]: F (For First)

Figure 4.39
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Specify first break point: Int
of (Pick the intersection of the two lines at “A”)
Specify second break point: End
of (Pick the endpoint of the line at “B”)

BREAKING CIRCLES

Circles can also be broken into arc segments with the BREAK command. There is only
one rule to follow when breaking circles; you must pick the two break points in a
counterclockwise direction when identifying the endpoints of the segment to be removed.

TryIt!: Open the drawing file 04_Break Circle. Study the following command sequence
and image for breaking circles.

Command: BR (For BREAK)
Select objects: (Select the circle)
Specify second break point or [First point]: F (For First)
Specify first break point: (Pick at “First Point”)
Specify second break point: (Pick at “Second Point”)

Figure 4.40

Figure 4.41
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BREAK AT POINT

You can also break an object at a selected point. The break is so small that you cannot find
it no matter how much you zoom in to the break point. As illustrated on the left in the
following image, the line is highlighted to prove that it consists of a continuous object.
Clicking on the Break at Point tool in the Modify toolbar activates the following command
sequence:

Command: BR (For BREAK)
Select object: (Select the line anywhere)
Specify second break point or [First point]: F (For First point)
Specify first break point: Mid
of (Pick the midpoint of the line)
Specify second break point: @ (For previous point)

The results are illustrated on the right in the following image. Here the line is again
selected. Notice that only half of the line selects because the line was broken at its
midpoint.

LEVEL II MODIFY COMMANDS

This second grouping of modify commands is designed to perform more powerful editing
operations compared with the Level I modify commands already discussed in this chapter.
These commands are briefly described in the following table:

Button Tool Key-In Function
Array AR Creates multiple copies of objects in a rectangular or circular pattern

Mirror MI Creates a mirror image of objects based on an axis of symmetry

Stretch S Used for moving or stretching the shape of an object

Pedit PE Used for editing polylines

Explode X Breaks a compound object such as a polyline, block, or dimension into
individual objects

None Lengthen LEN Changes the length of lines and arcs

Join JO Joins collinear objects to form a single unbroken object

Figure 4.42
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Button Tool Key-In Function
Undo U Used for backtracking or reversing the action of the previously used

command

Redo RD Reverses the effects of the previously used UNDO command operation

CREATING ARRAYS

If you need to create copies of objects that form rectangular or circular patterns, the
ARRAY command is available to help with this task. This is a very powerful command
that is dialog-box driven. If performing a rectangular array, you will need to supply the
number of rows and columns for the pattern in addition to the spacing between these rows
and columns. When performing a circular or polar array, you need to supply the center
point of the array, the number of items to copy, and the angle to fill. The next series of
pages documents both methods of performing arrays. Choose this command from one
of the following:

� The Modify toolbar or the Dashboard (2D Draw Control Panel)

� The pull-down menu (Modify > Array)

� The keyboard (AR or ARRAY)

CREATING RECTANGULAR ARRAYS

CREATING RECTANGULAR PATTERNS WITH POSITIVE OFFSET

The Array dialog box allows you to arrange multiple copies of an object or group of objects
in a rectangular or polar (circular) pattern. When creating a rectangular array, you are
prompted to enter the number of rows and columns for the array. A row is a group of
objects that are copied vertically in the positive or negative direction. A column is a group
of objects that are copied horizontally, also in the positive or negative direction.

TryIt!: Open the drawing file 04_Array Rectangular Positive. Suppose the object
illustrated on the left in the following image needs to be copied in a rectangular
pattern consisting of three rows and three columns.You also want a row offset of .50
units and a column offset of 1.25 units (measured center to center or from the same
location on each object) in order to space the rectangular shapes away from one
another. The result is illustrated on the right in the following image.

41131_04 6/18/2007 9:53:18 Page 36

36



Clicking Array in the Modify pull-down menu displays the Array dialog box. When it
appears, make the following changes. Be sure the Rectangular Array option is selected at
the top left corner of the dialog box. Enter 3 for the number of rows and 3 for the number
of columns. For Row Offset, enter a value of 1.00 units. For Column Offset, enter a value
of 2.00 units. Click the Select objects button in the upper-right corner of the dialog box.
This returns you to the drawing. Pick the rectangle and the two diagonal line segments.
Pressing ENTER when finished returns you to the Array dialog box. The Array dialog box
should now appear similar to the following image.

Observe the pattern in the preview image and notice that it has been updated to reflect
three rows and three columns. Notice also that the Preview < button in the lower-right
corner of the dialog box is active. Click this button to preview what the rectangular pattern
will look like in your drawing. Clicking the Accept button in the Array alert box in the

Figure 4.43

Figure 4.44
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following image completes the array operation. If you notice an error in the array results,
click the Modify button. This returns you to the Array dialog box and allows you to make
changes to any value. Clicking the Cancel button aborts the array operation and returns
you to the command prompt.

Tip: When performing rectangular arrays, a reference point must be established from
the object to be arrayed and the distance between the objects determined. Not only
must the spacing distance be used, but also the overall size of the object plays a role
in determining the spacing distances.With the total height of the original object at 0.50
and a required spacing between rows of 0.50, both object height and spacing result in
a distance of 1.00 from one reference point on an object to the next. A center-to-
center distance is often specified on engineering drawings, which becomes the row or
column spacing required.

CREATING RECTANGULAR PATTERNS WITH NEGATIVE OFFSETS

In the previous array example, the rectangular array illustrates a pattern that runs to the
right of and above the original figure. At times these directions change to the left of
and below the original object. The only change occurs in the distances between rows and
columns, where negative values dictate the direction of the rectangular array, as shown on
the right in the following image.

TryIt!: Open the drawing file 04_Array Rectangular Negative. Follow the illustration
in the image and the command prompt sequence below for performing this operation.

Activate the Array dialog box, as shown on the right in the following image. While in
Rectangular Array mode, set the number of rows to 3 and the number of columns to 2.
Because the directions of the array will be to the left of and below the original object, both
row and column distances will be negative values. When finished, preview the array; if the

Figure 4.45
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results are similar to the illustration on the left in the following image, click the OK button
to create the rectangular array pattern.

TryIt!: Open the drawing 04_Array I-Beam and create a rectangular pattern consisting of
four rows and five columns. Create a space of 20´ between both rows and columns.
Dimensions may be added at a later time.The results are displayed in the following image.

Figure 4.46

Figure 4.47
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Note: The I-beam and footing were converted to a block object with the insertion
point located at the center of the footing. For this reason, the I-beams can be arrayed
from their centers.

CREATING POLAR ARRAYS

Polar arrays allow you to create multiple copies of objects in a circular or polar pattern.
After selecting the objects to array, you pick a center point for the array in addition to the
number of items to copy and the angle to fill.

TryIt!: Open the drawing file 04_Array Polar and activate the Array dialog box. Be sure
to select the Polar Array option at the top of the dialog box. Click the Select objects
button at the top of the dialog box and pick the circle at “A” and the center line at
“B” as the objects to array. For the Center point of the array, click the Select objects
button and pick the intersection at “C” (this works only if the Intersection OSNAP
mode is checked). Enter 4 for the Total number of items and be sure the Angle to fill
is set to 360 (degrees). Also, verify that the box is checked next to Rotate items as
copied. The Array dialog box should appear similar to the illustration shown on the
right in the following image. Observe the results in the image icon and click
the Preview < button to see the results. Click the Accept button to complete the array
operation.

The results are illustrated on the left in the following image. This image also illustrates the
creation of 4 holes that fill an angle of 180º in the clockwise direction. Notice in the Array
dialog box shown on the right that an angle of –180º is given. This negative value drives
the array in the clockwise direction. Remember that positive angles drive polar arrays in the
counterclockwise direction.

Figure 4.48
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TryIt!: Open the drawing file 04_Array Polar Rotate. Illustrated in the following image
are three different results for arraying noncircular objects. The image on the right
illustrates a polar array formed by rotating the square object as it is being copied. In
the middle image, the square object is not being rotated as it is being copied. This
results in the reference point at “B” pulling the arrayed pattern slightly to the right and
off the main circular center line. To array rectangular or square objects in a polar
pattern without rotating the objects, first convert the square or rectangle to a block
with an insertion point located in the center of the square, as shown on the right in
the following image (this process will be covered in detail in chapter 16). Now all
squares lie an equal distance from their common center.

Figure 4.49

Figure 4.50
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MIRRORING OBJECTS

The MIRROR command is used to create a mirrored copy of an object or group of
objects. When performing a mirror operation, you have the option of deleting the original
object, which would be the same as flipping the object, or keeping the original object along
with the mirror image, which would be the same as flipping and copying. Choose this
command from one of the following:

� The Modify toolbar or the Dashboard (2D Draw Control Panel)

� The pull-down menu (Modify > Mirror)

� The keyboard (MI or MIRROR)

MIRRORING AND COPYING

The default action of the MIRROR command is to copy and flip the set of objects you
are mirroring. After selecting the objects to mirror, you identify the first and second points
of a mirror line. You then decide to keep or delete the source objects. The mirror operation
is performed in relation to the mirror line. Usually, most mirroring is performed in relation
to horizontal or vertical lines. As a result, it is usually recommended to turn on ORTHO
mode to force orthogonal mirror lines (horizontal or vertical).

TryIt!: Open the drawing file 04_Mirror Copy. Refer to the following prompts and
image for using the MIRROR command:

Command: MI (For MIRROR)
Select objects: (Select a point near “X”)
Specify opposite corner: (Select a point near “Y”)
Select objects: (Press ENTER to continue)
Specify first point of mirror line: (Select the endpoint of the

centerline at “A”)
Specify second point of mirror line: (Select the endpoint of the

centerline at “B”)
Delete source objects? [Yes/No] <N>: (Press ENTER for default)

Because the original object needed to be retained by the mirror operation, the image result
is shown on the right in the following image. The MIRROR command works well when
symmetry is required.
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MIRRORING BY FLIPPING

The illustration in the following image is a different application of the MIRROR
command. It is required to have all items that make up the bathroom plan flip but not copy
to the other side. This is a typical process involving “what if ” scenarios.

TryIt!: Open the drawing file 04_Mirror Flip. Use the following command prompts to
perform this type of mirror operation. The results are displayed on the right in the
following image.

Command: MI (For MIRROR)
Select objects: All (This selects all objects)
Select objects: (Press ENTER to continue)
Specify first point of mirror line: Mid
of (Select the midpoint of the line at “A”)
Specify second point of mirror line: Per
to (Select line “B,” which is perpendicular to point “A”)
Delete source objects? [Yes/No] <N>: Y (For Yes)

Figure 4.51
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MIRRORING TEXT

In addition to mirroring other object types, text can also be mirrored, as in the following
image of the duplex complex. Rather than copy and move the text into position for the
matching duplex half, you can include the text in the mirroring operation.

TryIt!: Open the drawing file 04_Mirror Duplex. Use the MIRROR command and
create a mirror image of the Duplex floor plan using line “AB” as the points for the
mirror line. Do not delete the source objects.Your finished results should be similar
to the following image.

MORE INFORMATION ON MIRRORING TEXT

There may be times when you mirror text, but the text is not right-reading. The mirror
operation makes the text backwards and difficult to read. This usually occurs with older
AutoCAD drawings.

Figure 4.52

Figure 4.53
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If this happens, a special system variable called MIRRTEXT is available. This variable
must be entered at the Command prompt. If this variable is set to a value of 1 (or on),
change the value to 0 (Zero, or off ).

Command: MIRRTEXT
New value for MIRRTEXT <1>: 0

STRETCHING OBJECTS

Use the STRETCH command to move a portion of a drawing while still preserving
the connections to parts of the drawing remaining in place. Choose this command from
one of the following:

� The Modify toolbar or the Dashboard (2D Draw Control Panel)

� The pull-down menu (Modify > Stretch)

� The keyboard (S or STRETCH)

THE BASICS OF STRETCHING

To perform this type of operation, you must use the Crossing option of “Select objects.”
In the following image, a group of objects is selected with the crossing box. Next, a base
point is identified at the approximate location of “C.” Finally, a second point of
displacement is identified with a polar coordinate or by using the Direct Distance mode.
Once the objects selected in the crossing box are stretched, the objects not only move to
the new location but also mend themselves.

TryIt!: Open the drawing file 04_Stretch. Use the following image and command
sequence to perform this task.

Command: S (For STRETCH)
Select objects to stretch by crossing-window or crossing-

polygon...
Select objects: (Pick a point at “A”)
Specify opposite corner: (Pick a point at “B”)
Select objects: (Press ENTER to continue)
Specify base point or displacement: (Select a point at “C”)
Specify second point of displacement: @.75<180 (Or use the Direct

Distance mode)

The results of performing this stretching operation are illustrated on the right in the
following image.
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HOW STRETCHING AFFECTS DIMENSIONS

Applications of the STRETCH command are illustrated in the following image, in which
a number of architectural features need to be positioned at a new location. The whole
success of using the STRETCH command on these features is in the selection of the
objects to stretch through the crossing box.

TryIt!: Open the drawing file 04_Stretch Arch. Use the following command sequence
and image to stretch the window, wall, and door the designated distances using the
Direct Distance mode or by entering a polar coordinate at the keyboard. Since each
of the stretch distances is a different value, the STRETCH command must be used
three separate times.

Figure 4.54

Figure 4.55
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STRETCHING USING MULTIPLE CROSSING WINDOWS

When identifying items to stretch by crossing box, you are not limited to a single crossing
box. You can surround groups of objects with multiple crossing boxes. All items selected
in this manner will be affected by the stretching operation.

TryIt!: Open the drawing file 04_Stretch Fence. Enter the STRETCH command and
construct three separate crossing boxes to select the top of the fence boards at “A,”
“B,” and “C,” as shown in the following image. When prompted for a base point or
displacement, pick a point on a blank part of your screen. Stretch these boards up at
a distance of 12" or 1'.

The results of performing the stretch operation on the fence are illustrated in the following
image. When you have to stretch various groups of objects in a single operation, you can
create numerous crossing boxes to better perform this task.

EDITING POLYLINES

Editing polylines can lead to interesting results. A few of these options will be
explained in the following pages. Choose this command from one of the following:

� The Modify II toolbar

� The pull-down menu (Modify > Object > Polyline)

� The keyboard (PE or PEDIT)

CHANGING THE WIDTH OF A POLYLINE

Illustrated on the left in the following image is a polyline of width 0.00. The PEDIT
command is used to change the width of the polyline to 0.10 units, as shown on the right
in the following image.

Figure 4.56

Figure 4.57
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TryIt!: Open the drawing file 04_Pedit Width. Refer to the following command
sequence to use the PEDIT command with the Width option.

Command: PE (For PEDIT)
Select polyline or [Multiple]: (Select the polyline)
Enter an option [Open/Join/Width/Edit vertex/Fit/Spline/Decurve/

Ltype gen/Undo]: W (For Width)
Specify new width for all segments: 0.10
Enter an option [Open/Join/Width/Edit vertex/Fit/Spline/Decurve/

Ltype gen/Undo]: (Press ENTER to exit this command)

JOINING OBJECTS INTO A SINGLE POLYLINE

It is very easy to convert regular objects such as lines and arcs into polylines (circles cannot
be converted). As you can convert individual objects into polylines, the results are a
collection of individual polylines. As long as the polyline endpoints match with one
another, these polylines can be easily joined into one single polyline object using the Join
option of the PEDIT command.

TryIt!: Open the drawing file 04_Pedit Join. Refer to the following command sequence
and image to use this command.

Command: PE (For PEDIT)
Select polyline or [Multiple]: (Select the line at “A”)
Enter an option [Close/Join/Width/Edit vertex/Fit/Spline/Decurve/

Ltype gen/Undo]: J (For Join)
Select objects: (Pick a point at “B”)
Specify opposite corner: (Pick a point at “C”)
Select objects: (Press ENTER to join the lines)
56 segments added to polyline
Enter an option [Open/Join/Width/Edit vertex/Fit/Spline/Decurve/

Ltype gen/Undo]: (Press ENTER to exit this command)

Figure 4.58
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CURVE GENERATION

Polylines can be edited to form various curve-fitting shapes. Two curve-fitting modes are
available, namely, Splines and Fit Curves.

GENERATING SPLINES

The Spline option produces a smooth-fitting curve based on control points in the form of
the vertices of the polyline.

TryIt!: Open the drawing file 04_Pedit Spline Curve. Refer to the following command
sequence and image to use this command.

Command: PE (For PEDIT)
Select polyline or [Multiple]: (Select the polyline frame)
Enter an option [Close/Join/Width/Edit vertex/Fit/Spline/Decurve/

Ltype gen/Undo]: S (For Spline)
Enter an option [Close/Join/Width/Edit vertex/Fit/Spline/Decurve/

Ltype gen/Undo]: (Press ENTER to exit this command)

The results of creating a spline curve from a polyline are shown on the right in the
following image.

GENERATING FIT CURVES

The Fit Curve option passes entirely through the control points, producing a less
desirable curve.

Figure 4.59

Figure 4.60
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TryIt!: Open the drawing file 04_Pedit Fit Curve. Refer to the following command
sequence and image to use this command.

Command: PE (For PEDIT)
Select polyline or [Multiple]: (Select the polyline)
Enter an option [Close/Join/Width/Edit vertex/Fit/Spline/Decurve/

Ltype gen/Undo]: F (For Fit)
Enter an option [Close/Join/Width/Edit vertex/Fit/Spline/Decurve/

Ltype gen/Undo]: (Press ENTER to exit this command)

The results of creating a fit curve from a polyline are shown on the right in the
following image.

LINETYPE GENERATION OF POLYLINES

The Linetype Generation option of the PEDIT command controls the pattern of the
linetype from polyline vertex to vertex. In the polyline illustrated on the left in
the following image, the hidden linetype is generated from the first vertex to the second
vertex. An entirely different pattern is formed from the second vertex to the third vertex,
and so on. The polyline illustrated on the right in the following image has the linetype
generated throughout the entire polyline. In this way, the hidden linetype is smoothed
throughout the polyline.

TryIt!: Open the drawing file 04_Pedit Ltype Gen. Refer to the following command
sequence and image to use this command.

Command: PE (For PEDIT)
Select polyline or [Multiple]: (Select the polyline)
Enter an option [Close/Join/Width/Edit vertex/Fit/Spline/Decurve/

Ltype gen/Undo]: Lt (For Ltype gen)
Enter polyline linetype generation option [ON/OFF] <Off>: On
Enter an option [Close/Join/Width/Edit vertex/Fit/Spline/Decurve/

Ltype gen/Undo]: (Press ENTER to exit this command)

Figure 4.61
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OFFSETTING POLYLINE OBJECTS

Once a group of objects has been converted to and joined into a single polyline object, the
entire polyline can be copied at a parallel distance using the OFFSET command.

TryIt!: Open the drawing file 04_Pedit Offset. Use the OFFSET command to copy the
shape in the following image a distance of 0.50 units to the inside.

Command: O (For OFFSET)
Specify offset distance or [Through/Erase/Layer] <1.0000>: 0.50
Select object to offset or [Exit/Undo] <Exit>: (Select the

polyline at “A”)
Specify point on side to offset or [Exit/Multiple/Undo] <Exit>:

(Select a point anywhere near “B”)
Select object to offset or [Exit/Undo] <Exit>: (Press ENTER to

exit this command)

Because the object was converted to a polyline, all objects are offset at the same time, as
shown on the right in the following image.

MULTIPLE POLYLINE EDITING

Multiple editing of polylines allows for multiple objects to be converted to polylines. This
is accomplished with the PEDIT command and the Multiple option. Illustrated on the left
in the following image is a rectangle and four slots, all considered individual objects. When
you run the Multiple option of the PEDIT command, not only can you convert all objects
at once into individual polylines but you can join the endpoints of common shapes as well.

Figure 4.62

Figure 4.63

41131_04 6/15/2007 16:37:51 Page 51

Modifying Your Drawings 51



The result of editing multiple polylines and then joining them is illustrated on the right
in the following image.

TryIt!: Open the drawing file 04_Pedit Multiple1. Use the prompt sequence below and
the following image to illustrate how the MPEDIT command is used.

Command: PE (For PEDIT)
Select polyline or [Multiple]: M (For Multiple)
Select objects: All
Select objects: (Press ENTER to continue)
Enter an option [Close/Open/Join/Width/Fit/Spline/Decurve/Ltype

gen/Undo]: J (For Join)
Join Type = Extend
Enter fuzz distance or [Jointype] <0.0000>: (Press ENTER to

accept this default value)
15 segments added to 5 polylines
Enter an option [Close/Open/Join/Width/Fit/Spline/Decurve/Ltype

gen/Undo]: (Press ENTER to exit)

As a general rule when joining polylines, you cannot have gaps present or overlapping
occurring when performing this operation. This is another feature of using the Multiple
option of the PEDIT command. This option works best when joining two objects that
have a gap or overlap. After selecting the two objects to join, you will be asked to enter a
fuzz factor. This is the distance used by this command to bridge a gap or trim overlapping
lines. You could measure the distance between two objects to determine this value. Study
the following example for automatically creating corners in objects using a fuzz factor.

Figure 4.64
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TryIt!: Open the drawing file 04_Pedit Multiple2. In this example, one of the larger
gaps was measured to be .12 units in length.As a result, a fuzz factor slightly larger than
this calculated value is used (.13 units).The completed object is illustrated on the right
in the following image.You may have to experiment with various fuzz factors before
you arrive at the desired results.

Command: PE (For PEDIT)
Select polyline or [Multiple]: M (For Multiple)
Select objects: All
Select objects: (Press ENTER to continue)
Enter an option [Close/Open/Join/Width/Fit/Spline/Decurve/Ltype

gen/Undo]: J (For Join)
Join Type = Extend
Enter fuzz distance or [Jointype] <0.25>: .13
11 segments added to polyline
Enter an option [Close/Open/Join/Width/Fit/Spline/Decurve/Ltype

gen/Undo]: (Press ENTER to exit)

EXPLODING OBJECTS

Using the EXPLODE command on a polyline, dimension, or block separates the
single object into its individual parts. Choose this command from one of the following:

� The Modify toolbar or the Dashboard (2D Draw Control Panel)

� The pull-down menu (Modify > Explode)

� The keyboard (X or EXPLODE)

Illustrated on the left in the following image is a polyline that is considered one object.
Using the EXPLODE command and selecting the polyline breaks the polyline into
numerous individual objects, as shown on the right in the following image.

Figure 4.65
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Command: X (For EXPLODE)
Select objects: (Select the polyline)
Select objects: (Press ENTER to perform the explode operation)

Note: Dimensions consist of extension lines, dimension lines, dimension text, and
arrowheads, all grouped into a single object. (Dimensions are covered in chapter 11,
“Adding Dimensions to Your Drawing.”) Using the EXPLODE command on a dimen-
sion breaks the dimension down into individual extension lines, dimension lines,
arrowheads, and dimension text.This is not advisable, because the dimension value will
not be updated if the dimension is stretched along with the object being dimensioned.
Also, the ability to manipulate dimensions with a feature called grips is lost. Grips are
discussed in chapter 7.

LENGTHENING OBJECTS

The LENGTHEN command is used to change the length of a selected object without
disturbing other object qualities such as angles of lines or radii of arcs. Choose this
command from one of the following:

� The pull-down menu (Modify > Lengthen)

� The keyboard (LEN or LENGTHEN)

TryIt!: Open the drawing file 04_Lengthen1. Use the illustration in the following image
and the command sequence below for performing this task.

Command: LEN (For LENGTHEN)
Select an object or [DElta/Percent/Total/DYnamic]: (Select line

“A”)
Current length: 12.3649
Select an object or [DElta/Percent/Total/DYnamic]: T (For Total)
Specify total length or [Angle] (1.0000)>: 20
Select an object to change or [Undo]: (Select the line at “A”)
Select an object to change or [Undo]: (Press ENTER to exit)

Figure 4.66
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Tip: After supplying the new total length of any object, be sure to select the desired
end to lengthen when you are prompted to select an object to change.

JOINING OBJECTS

For special cases in which individual line segments need to be merged together as a single
segment, the JOIN command can be used to accomplish this task. Usually this occurs
when gaps occur in line segments and all segments lie in the same line of sight. This
condition is sometimes referred to as collinear. Rather than connect the gaps with
additional individual line segments, considered very unproductive and poor in practice, use
JOIN to connect all segments as one. Choose this command from one of the following:

� The Modify toolbar or the Dashboard (2D Draw Control Panel)

� The pull-down menu (Modify > Join)

� The keyboard (J or JOIN)

TryIt!: Open the drawing file 04_Join. Pick one line segment as the source.Then select
other line segments to join to the source. Use the following command prompt and
image to join various segments using the JOIN command.

Command: J (For Join)
Select source object: (Select line “A”)
Select lines to join to source: (Select line “B”)
Select lines to join to source: (Select line “C”)
Select lines to join to source: (Press ENTER to join the

segments)
2 lines joined to source

Figure 4.67
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Continue using the JOIN command on the other line segments. A different JOIN
command must be used for each group of line segments that appears broken in the
following image.

UNDOING OPERATIONS

The UNDO command can be used to undo the previous task or command action.
Choose this command from one of the following:

� The Standard toolbar

� The pull-down menu (Edit > Undo)

� The keyboard (U or UNDO)

� Select anywhere in the drawing and right-click

For example, if you draw an arc followed by a line followed by a circle, issuing the UNDO
command will undo the action caused by the most recent command; in this case, the circle
would be removed from the drawing database. This represents one of the easiest ways to
remove data or backtrack the drawing process.
Expanding the Undo list found in the Standard toolbar, shown in the following image,
allows you to undo several actions at once. From this example, notice that the Line, Trim,
Fillet, and Offset actions are highlighted for removal.

Figure 4.68

Figure 4.69
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Note: When grouping actions to be undone, you cannot, in the previous image, for
example, highlight Line, skip Trim, and highlight Fillet to be removed.The groupings to
undo must be strung together in this dialog box.

REDOING OPERATIONS

You can also reverse the effect of the UNDO command by using REDO immediately after
the UNDO operation. Choose this command from one of the following:

� The Standard toolbar

� The pull-down menu (Edit > Redo)

� The keyboard (REDO)

Clicking the REDO command button from the Standard toolbar negates one
UNDO operation. You can click on this button to cancel the effects of numerous UNDO
operations.
As with UNDO, you can also REDO several actions at once through the Redo list shown
in the following image. This list can be accessed from the Standard toolbar.

Note: REDO only works if you have undone a previous operation. Otherwise, REDO
remains inactive.

Figure 4.70
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TUTORIAL EXERCISE: ANGLE.DWG

PURPOSE

This tutorial is designed to allow you to construct a one-view drawing of the angle as
shown in the previous image using the ARRAY and LENGTHEN commands.

SYSTEM SETTINGS

Use the Drawing Units dialog box and change the precision of decimal units from 4 to 2
places. Use the current default settings for the limits of this drawing, (0,0) for the
lower-left corner and (12,9) for the upper-right corner. Check to see that the following
Object Snap modes are already set: Endpoint, Extension, Intersection, Center.

LAYERS

Create the following layer with the format:
Name Color Linetype
Object White Continuous

SUGGESTED COMMANDS

Make the Object layer current. Begin this drawing by constructing line “AB,” which is
horizontal. Use the ARRAY command to copy and rotate line “AB” at an angle of 150° in
the clockwise direction. Once the line is copied and rotated, use the LENGTHEN
command and modify the new line to the designated length. Repeat this procedure for
lines “CD,” “DE,” and “EF.” Complete the drawing by constructing a line segment from
the endpoint at vertex “F” to the endpoint at vertex “A.” This object could also have been
constructed using a polar angle setting of 5° and a polar setting relative to the previous line.

Figure 4.71
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Step 1
Draw line “AB” using the Polar coordinate or Direct Distance mode, as shown in the
following image. (Line “AB” is considered a horizontal line.)

Step 2
One technique of constructing the adjacent line at 150° from line “AB” is to use the Array
dialog box, as shown on the left in the following image, and perform a polar operation.
Select line “AB” as the object to array, pick the intersection at “B” as the center of the array,
and enter a value of −150° for the angle to fill. Entering a negative angle copies the line
in the clockwise direction. The value of your array center point will be different from the
value displayed in the dialog box.
The result is shown on the right in the following image.

Step 3
The array operation allowed line “AB” to be rotated and copied at the correct angle, namely
−150°. However, the new line is the same length as line “AB.” Use the LENGTHEN
command to increase the length of the new line to a distance of 5.00 units. Use the Total
option, specify the new total length of 5.00, and select the end of the line at “1” as the
object to change, as shown on the left in the following image.

Command: LEN (For LENGTHEN)
Select an object or [DElta/Percent/Total/DYnamic]: T (For Total)
Specify total length or [Angle] <1.00)>: 5.00

Figure 4.72

Figure 4.73
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Select an object to change or [Undo]: (Pick the end of the line
at “1”)

Select an object to change or [Undo]: (Press ENTER to exit this
command)

The result is shown on the right in the following image.

Step 4
Use the Array dialog box, shown on the left in the following image, and perform a polar
operation. Select line “BC” as the object to array, pick the intersection at “C” as the center
of the array, and enter a value of −55° for the angle to fill. Entering a negative angle copies
the line in the clockwise direction.

Step 5
Then use the LENGTHEN command to reduce the length of the new line from 5.00
units to 3.00 units. Use the Total option, specify the new total length of 3.00, and select
the end of the line at “1” as the object to change, as shown on the left in the
following image.

Command: LEN (For LENGTHEN)
Select an object or [DElta/Percent/Total/DYnamic]: T (For Total)

Figure 4.74

Figure 4.75
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Specify total length or [Angle] <5.00)>: 3.00
Select an object to change or [Undo]: (Pick the end of the line

at “1”)
Select an object to change or [Undo]: (Press ENTER to exit this

command)

The result is shown on the right in the following image.

Step 6
Use the Array dialog box and perform another polar operation. Select line “CD” as the
object to array, as shown on the left in the following image, pick the intersection at “D”
as the center of the array, and enter a value of 120° for the angle to fill. Entering a positive
angle copies the line in the counterclockwise direction.
Then use the LENGTHEN command to reduce the length of the new line from 3.00
units to 1.00 unit, as shown on the right in the following image.

Command: LEN (For LENGTHEN)
Select an object or [DElta/Percent/Total/DYnamic]: T (For Total)
Specify total length or [Angle] <3.00)>: 1.00
Select an object to change or [Undo]: (Pick the end of the line

at “1”)
Select an object to change or [Undo]: (Press ENTER to exit this

command)

Figure 4.76
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Step 7
Use the Array dialog box and perform the final polar operation. Select line “DE” as the
object to array, pick the intersection at “E” as the center of the array, and enter a value of
−70° for the angle to fill. Entering a negative angle copies the line in the clockwise
direction.
Then use the LENGTHEN command to increase the length of the new line from 1.00
unit to 7.00 units, as shown on the right in the following image.

Command: LEN (For LENGTHEN)
Select an object or [DElta/Percent/Total/DYnamic]: T (For Total)
Specify total length or [Angle] <1.00)>: 7.00
Select an object to change or [Undo]: (Pick the end of the line

at “1”)
Select an object to change or [Undo]: (Press ENTER to exit this

command)

Figure 4.77

Figure 4.78
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Step 8
Connect endpoints “F” and “A” with a line as shown in the following image.

Command: L (For LINE)
Specify first point: (Pick the endpoint of the line at “F”)
Specify next point or [Undo]: (Pick the endpoint of the line at

“A”)
Specify next point or [Undo]: (Press ENTER to exit this command)

The completed drawing is illustrated on the right in the following image. You may add
dimensions at a later date.

TUTORIAL EXERCISE: GASKET.DWG

Figure 4.79

Figure 4.80
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PURPOSE

This tutorial is designed to allow you to construct a one-view drawing of the gasket using
the Array dialog box.

SYSTEM SETTINGS

Use the current default settings for the units and limits of this drawing, (0,0) for the
lower-left corner and (12,9) for the upper-right corner. Check to see that the following
Object Snap modes are already set: Endpoint, Extension, Intersection, Center, and
Quadrant.

LAYERS

Create the following layers with the format:

Name Color Linetype
Object White Continuous
Center Yellow Center

SUGGESTED COMMANDS

Draw the basic shape of the object using the LINE and CIRCLE commands. Lay out a
centerline circle; draw one of the gasket tabs at the top of the center circle. Use the Array
dialog box to create four copies in the −180º direction and two copies in the 80º direction.
Trim out the excess arc segments to form the gasket. Convert the outer profile of the
gasket into one continuous polyline object and offset this object .125 units to the outside
of the gasket.

Step 1
Use existing unit and limit settings. Create an Object and a Center layer. Assign the
Center linetype to the Center layer.
Make the Object layer current and construct a circle of 2.00 radius with its center at
absolute coordinate 4.00,4.00, as shown on the left in the following image.
Make the Center layer current and construct a circle of 2.25 radius using the previous
center point, as shown on the right in the following image. Change the linetype scale from
1.00 to 0.50 units using the LTSCALE (LTS) command.
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Step 2
Make the Object layer current again and construct a circle of radius .75" from the quadrant
at the top of the centerline circle, as shown on the left in the following image. Also
construct a circle of .75" in diameter from the same quadrant at the top of the centerline
circle, as shown on the right in the following image.

Step 3
Copy the two top circles just created in a polar (circular) pattern using the Array dialog
box. Use the center of the 2.00-radius circle as the center point of the array. Change the
total number of items to 4 and the angle to fill to −180º, as shown on the left in the
following image. The negative angle drives the array in the clockwise direction, as shown
on the right in the following image.

Figure 4.81

Figure 4.82
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Step 4
Perform another array operation on the top two circles. Again, use the center of the 2.00-radius
circle as the center point of the array. Change the total number of items to 2 and the angle to
fill to 80º, as shown on the left in the following image. The positive angle drives the array in
the counterclockwise direction, as shown on the right in the following image.

Figure 4.83

Figure 4.84
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Step 5
Trim out the inside edges of the five circles labeled “A” through “E” using the dashed circle
as the cutting edge, as shown on the left in the following image. The results are displayed
on the right.

Step 6
Use the TRIM command again. Select the five dashed arc segments as cutting edges and
trim away the portions labeled “A” through “E,” as shown on the left in the following
image. The results are displayed on the right.

Figure 4.85

Figure 4.86
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Step 7
Fillet the inside corners of the .75-radius arcs with the 2.00-radius arc using the FILLET
command and a radius set to .25". These corners are marked by a series of points, shown
on the left in the following image. The results are displayed on the right.

Step 8
Create the large 1.50-radius hole in the center of the gasket using the CIRCLE command.
Change the outer perimeter of the gasket into one continuous polyline object using the
PEDIT command. Use the Join option of this command to accomplish this task. Finally,
create a copy of the outer profile of the gasket a distance of .125" using the OFFSET
command. Offset the profile to the outside at “A” as shown on the left in the following
image. The completed gasket is displayed on the right.

Figure 4.87
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TUTORIAL EXERCISE: TILE.DWG

PURPOSE

This tutorial is designed to use the OFFSET and TRIM commands to complete the
drawing of the floor tile shown in the previous image.

SYSTEM SETTINGS

Use the Drawing Units dialog box and change the units of measure from decimal to
architectural units. Keep the remaining default settings. Use the LIMITS command and
change the limits of the drawing to (0,0) for the lower-left corner and (10´,8´) for the

Figure 4.88

Figure 4.89
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upper-right corner. Use the ZOOM command and the All option to fit the new drawing
limits to the display screen.
Check to see that the following Object Snap modes are currently set: Endpoint, Extension,
Intersection, and Center.

LAYERS

Create the following layer with the format:

Name Color Linetype
Object White Continuous
Center Yellow Center

SUGGESTED COMMANDS

Make the Object layer current. Use the RECTANGLE command to begin the inside
square of the tile. The OFFSET command is used to copy the inner square a distance of
5" to form the outer square. The ARRAY command is used to copy selected line segments
in a rectangular pattern at a specified distance. The TRIM command is then used to form
the inside tile patterns.

Step 1
Verify that the current units are set to architectural and the drawing limits set to 10´, 8´
for the upper-right corner. Be sure to perform a ZOOM-All on your screen. Draw the
inner 3'-0" square using the RECTANGLE command, as shown on the left in the
following image. Then offset the square 5" to the outside using the OFFSET command,
as shown on the right in the following image. Because the square was drawn as a polyline,
the entire shape offsets to the outside.

Figure 4.90
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Step 2
Notice that when you click on the inner square on the left in the following image, the
entire object highlights because it consists of a single polyline object. Use the EXPLODE
command to break up the inner square into individual line segments. Now when you click
on a line that is part of the inner square, only that line highlights, as shown on the right
in the following image. This procedure is required in order to perform the next step.

Step 3
You will now begin laying out the individual tiles with a spacing of 3" between each. The
Array dialog box will be used to accomplish this. Activate the Array dialog box, change the
number of rows to 1 and the number of columns to 12. Also change the distance between
columns to 3". Finally, pick the line at “A” as the object to array, as shown on the left in
the following image. Your display should appear similar to the illustration on the right
in the following image.

Figure 4.91
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Step 4
The bottom horizontal line needs to be copied multiple times vertically. Activate the Array
dialog box; change the number of rows to 12 and the number of columns to 1. Also change
the distance between rows to 3". Finally, pick the line at “A” as the object to array, as shown
on the left in the following image. Your display should appear similar to the illustration on
the right in the following image.

Step 5
The TRIM command will now be used to clean up the inner lines and form the 3" tiles.
When using TRIM, do not press ENTER and select all cutting edges. This would be
counterproductive. Instead, select the two vertical dashed lines, as shown on the left in the

Figure 4.92

Figure 4.93
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following image. Then trim away the horizontal segments in zones “A” through “D,” as
shown on the right in the following image. Remember that if you make a mistake and trim
the wrong line, you can enter U in the command line to restore the previous trimmed line
and pick the correct line.

Step 6
Use the TRIM command again to finish cleaning up the object. Select the two horizontal
dashed lines as cutting edges, as shown on the left in the following image. Then trim away
the vertical segments in zones “A” through “E,” as shown on the right in the following
image. This completes this exercise on creating the tile.

Figure 4.94

Figure 4.95
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PROBLEMS FOR CHAPTER 4

DIRECTIONS FOR PROBLEMS 4–1 THROUGH 4–14

Construct each one-view drawing using the appropriate coordinate mode or Direct Distance
mode. Utilize advanced commands such as ARRAY and MIRROR whenever possible.

Problem 4–1

Problem 4–2

Figure 4.96

Figure 4.97
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Problem 4–3

Problem 4–4

Figure 4.98

Figure 4.99
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Problem 4–5

Problem 4–6

Figure 4.100

Figure 4.101
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Problem 4–7

Problem 4–8

Figure 4.102

Figure 4.103
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Problem 4–9

Problem 4–10

Figure 4.104

Figure 4.105
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Problem 4–11

Problem 4–12

Figure 4.106

Figure 4.107
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Problem 4–13

Problem 4–14

Figure 4.108

Figure 4.109
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